Yamaha Viking Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Getting ready to throw some 29.5 swamplites on my viking 6 not sure if it will work or not. Anyone running 29 or bigger tires without a lift? I have 27's on there now and they are fine. Not really concerned with power loss right now, planning on installing a clutch kit eventually. Thanks.
 

·
Registered
Joined
·
15 Posts
I have 29 inch big horns and they would rub at full lock in any kind of bind. Got a highlifter lift kit and that took care of the problem.
 
  • Like
Reactions: Robleticia

·
Registered
Joined
·
81 Posts
Put 29.5 terms on my Viking 6. Rubbed put 2" highlighter now front only rubs fully turned in awkward positions.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
218 Posts
Looks good!!!!! I'm running 28 swamplites on mine with 2" lift. Runs great handles great and looks good.
 

·
Registered
Joined
·
161 Posts
I'm running 30s with a 3" lift and only rub in awkward positions
 

·
Premium Member
Joined
·
218 Posts
Looks great with the lift. Now let's see it getting muddy! LOL. Seriously, its a good looking ride.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 · (Edited)
Thank you. Havent had a chance to test it out yet with the 29's and the lift, but it went through some tough spots with 27's and no lift.It'll be thoroughly tested this summer here in Kodiak though.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Looks good, are those swamplites on factory rims? Not rubbing on tierod ends?
Cheers


Sent from my iPhone using Tapatalk
Yes 29.5" swamplites on factory rims. didn't even attempt to drive it without the lift installed. definitely would have rubbed. plenty of room after the 2" lift though.
 
1 - 13 of 13 Posts
Top