Yamaha Viking Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hello everyone. Since I am a new owner of a Viking and needing some help thought I would find a forum that could possibly help me. I got my Viking in March of this year and have been riding just about every week end since. I started noticing a metal clicking noise about three to four weeks ago coming from the back. It only does it when I let off the gas pedal. It sounds like something is loose and it's something metal tapping against something. It doesn't always do it and sometimes loud and other times I can barely hear or not at all. I just had the first service done and was hoping that would take care of it but no such luck. The service guy said the noise I was hearing was normal but the noise I'm hearing wasn't what he was talking about. I know what that noise is and one of the guys I ride with doesn't have the same on his Viking that I'm hearing. If anyone has had this happen and knows the problem let me know thanks

Riding in a red 2016 Yamaha Viking.
 

·
Banned
Joined
·
177 Posts
hello everyone. Since I am a new owner of a Viking and needing some help thought I would find a forum that could possibly help me. I got my Viking in March of this year and have been riding just about every week end since. I started noticing a metal clicking noise about three to four weeks ago coming from the back. It only does it when I let off the gas pedal. It sounds like something is loose and it's something metal tapping against something. It doesn't always do it and sometimes loud and other times I can barely hear or not at all. I just had the first service done and was hoping that would take care of it but no such luck. The service guy said the noise I was hearing was normal but the noise I'm hearing wasn't what he was talking about. I know what that noise is and one of the guys I ride with doesn't have the same on his Viking that I'm hearing. If anyone has had this happen and knows the problem let me know thanks

Riding in a red 2016 Yamaha Viking.
Check the seat belt attachments at the role cage. There are several videos out that you can hear those things "clinking." Easiest way to solve this is to take them off and add those rubber garden hose washers.
 
1 - 4 of 4 Posts
Top