Yamaha Viking Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Has anyone had any issues with the overheat light coming on and coolant being sprayed from somewhere. I've searched and searched and can not find a single place where it's spraying from. It also seems to only be doing it when it's cold outside. The entire summer here I never had a issue and now that it's winter it happens every time I take it out of the garage. I even asked the dealer about it and they could not point me in the right direction.
 

·
Registered
Joined
·
256 Posts
hmm sounds odd.. I see your from the north pole.. ,.. is there a possibility that you need a stronger ratio anti freeze?? what temps you running in?? the antifreeze could be freezing (seen it happen)
 

·
Banned
Joined
·
261 Posts
I dont know how the cooling system works on the Viking but could you have a bad thermostat?
 

·
Registered
Joined
·
256 Posts
Funny thing....My heep does the same thing on cold days. It'll leak out by a hose clamp...I snug it a bit more and it gets rid of it....for a week or two...during summer, never have the issue...lol.

Go figure. Sorry I wasn't of much help but thought I'd share my experience.
 

·
Registered
Joined
·
256 Posts
Robert would yours completely empty the reservoir of coolant?
Nope. Reservoir stays at its proper level.

My Jeep didn't really spray anything, more like it dripped coolant.

It wouldn't hurt to check the radiator level while the Viking is running....maybe there's air in the system....can't always trust 'em factory boys.
 

·
Registered
Joined
·
2 Posts
Over heating viking VI and dumping coolant

Has anyone had any issues with the overheat light coming on and coolant being sprayed from somewhere. I've searched and searched and can not find a single place where it's spraying from. It also seems to only be doing it when it's cold outside. The entire summer here I never had a issue and now that it's winter it happens every time I take it out of the garage. I even asked the dealer about it and they could not point me in the right direction.
I see there are a few out there having similar problems with over heating and coolant. My Viking VI is driving me nuts!

Last fall the rad fell out of the mounts and punched a hole in the rad core. Yamaha replaced the rad under warrant citing faulty mounting brackets. Since then I have had nothing but over heating problems.

They have replaced the thermostat twice, the head gasket twice, the water pump once and the head was milled; still overheats and dumps coolant out of the water pump drain hose, emptying the reservoir and depleting the rad. I am at my wits end with this SxS and hope that someone can perhaps shed some light on the issue. The dealership has been great but Yamaha Canada is beginning to dig in their heels saying the machine is out of warranty...If anyone has any suggestions, I would sincerely appreciate the insight. We need this machine for work and play at the cottage as out only source of heat is wood and we use a lot in the winter.
 

·
Premium Member
Joined
·
601 Posts
Still sounds like a head gasket leak. I have never had the thermostat housing apart, so I don't know if you can run it without the thermostat at all? If you could, I would try that and see if it makes a difference.
 

·
Registered
Joined
·
2 Posts
Still sounds like a head gasket leak. I have never had the thermostat housing apart, so I don't know if you can run it without the thermostat at all? If you could, I would try that and see if it makes a difference.
Yes you can and yes I did. Still ran hot and dumped coolant.
 
1 - 11 of 11 Posts
Top