Yamaha Viking Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 · (Edited)
I noticed that when parked with the engine off or running ,I have a clunk in the steering system. I have the power steering model. If I have my wheel straight and turn 1 complete turn left or right it clunks every time. Anyone else notice this on there ride? I would think the 3 and 6 seaters have the same steering set up. While driving it only does this at full lock.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #3 · (Edited)
Now it seems only to do it when riding and at full lock left or right. My T4 also did the same.

Not as noticeable as I thought. I guess with the quiter cab on the 6 vs my noise makin T4 I can hear more... Lol
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #4 ·
I have one and never noticed any clunking at all in mine but has stock wheel and tires still on it
Do you have the 6 seater?
 

·
Registered
Joined
·
12 Posts
I have recently had the same problem with the clunk in my steering system I took it in to the shop and they said it was definitely in the power steering motor and they replaced it under warranty and it fixed it. They said they have never seen a power steering fail like that. It still worked but just had that clunk in it.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
8 Posts
Mine has a little spot on both left and right to where it almost seems like something is rubbing but it has a little pop to it at that spot. Notice it at low speeds but never really had any issues because of it.


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top